How to Run HTM School Visualizations

The visualizations are not written in python. You must run a web server.

hi. is there code of spatial pooling algorithm and temporal memory in this package or not?

hi, i had read this tutorial but i dont understand step 1 ,that where i should use this commands, i mean in which environment i should enter this codes??
export HTM_SERVER=<
export CELL_VIZ=<
export HTM_VIZ=<
and it should be exactly with this address or not ? i should change it by my path in my computer?

Are you in Windows? Because this probably does not run in windows.

yes i am in windows 10.

Those are just environment variables you should set in the shell.

I’m trying to run the visualizations on windows 10, but I have been unable to get the webserver running. When I run the code

python webserver.py 8080

I get the error

no module name capnp

and I cant find this library for windows 64 ,As an aside I already have MinGW GCC for Python as well as mingGW 64 installed. and also install nupic correctly (the version that you cited in above and in https://github.com/numenta/nupic ),Any help would be much appreciated.

hi @rhyolight
did the visualization work on the windows because, as I see in the comments there is a several problems in the windows

hi dear matt, when i click on episode 7 (random spatial pooler) nothing loaded, can you tell me what should i do?(I run in linux (manjaro) and in python 2.7 )

Episode 7 is the first episode that requires the NuPIC server to be running. Make sure it is running and not throwing errors.

2 Likes

somebody made a working Docker config: https://github.com/rconaway/groks.htm/tree/master/school-viz worked upon first run

1 Like

Awesome visualisations. However it took me some time to get it running because of incompatible version of nodejs, the webpack command did not work (I had to follow instructions in the cell-viz repo) and it unpacked into dist/cell-viz-3d-1.4.9.min.js instead to out/dyson.js. Maybe it would be good to mention this in the guide.

Someday I’ll be back in this codebase and I’ll update it all. In the meantime, feel free to create a PR.

Hi all,
I am wondering if you manged to run the simulation for Ep8/Sp Learning Comparison.
I read in some comment that Matt is not using redis-server in that Episode but capnp.

Anyway the error log I get is the following:

127.0.0.1:56220 - - [31/Jan/2019 17:08:32] "HTTP/1.1 POST /_sp/" - 200 OK
		_conjurePermanences: 0.432464122772 seconds
	Saving SP b87ba075 to disk...
Traceback (most recent call last):
  File "/home/alessandro/.local/share/virtualenvs/nupic-yn_sXeWq/local/lib/python2.7/site-packages/web/application.py", line 239, in process return self.handle()
  File "/home/alessandro/.local/share/virtualenvs/nupic-yn_sXeWq/local/lib/python2.7/site-packages/web/application.py", line 230, in handle return self._delegate(fn, self.fvars, args)
  File "/home/alessandro/.local/share/virtualenvs/nupic-yn_sXeWq/local/lib/python2.7/site-packages/web/application.py", line 462, in _delegate return handle_class(cls)
  File "/home/alessandro/.local/share/virtualenvs/nupic-yn_sXeWq/local/lib/python2.7/site-packages/web/application.py", line 438, in handle_class return tocall(*args)
  File "../nupic-history-server/webserver.py", line 88, in POST sp.save()
  File "/home/alessandro/Nextcloud/Leuphana/Masterthesis/Anomaly_Detection/nupic-history-server/nupic_history/sp_facade.py", line 53, in save ioClient.saveEncoding(self._input, id, iteration)
  File "/home/alessandro/Nextcloud/Leuphana/Masterthesis/Anomaly_Detection/nupic-history-server/nupic_history/io_client.py", line 63, in saveEncoding self._writeData(key, encoding)
  File "/home/alessandro/Nextcloud/Leuphana/Masterthesis/Anomaly_Detection/nupic-history-server/nupic_history/io_client.py", line 43, in _writeData with open(path, "w") as fileout:
IOError: [Errno 2] No such file or directory: './working/htm_encoding_b87ba075_0.npc'

127.0.0.1:56222 - - [31/Jan/2019 17:08:32] "HTTP/1.1 POST /_sp/" - 500 Internal Server Error

Thank you in advance for your help.

Maybe your workingDir doesn’t exist? Create it? Or change it here:

1 Like

@rhyolight you are good! Thank you

Now the page frame is loading and I got no error, but still no visualizations…is there any tweak I am missing?

PS: using WASD this link to Ep.10 you posted works and run: How to Run HTM School Visualizations

@vedhas did yon manage to solve your issue? How to Run HTM School Visualizations

Are there any errors in the nupic-history-server logs? Or the web server logs? Or the web client logs?

1 Like

Hello,
I see and experience myself how
this project is very hard to setup and
that there are many errors in different environment.
I thus thought, why couldn’t this run on a public server?
That would make it easier for all of us to use this,
if we could just go to a web site and would immediatly be
prompted with an alredy running instance of the program.

1 Like

Thanks for joining, and for the feedback.

Please see Building HTM Systems (WIP Document). I am working on something I think will be better than this in the long run.