Nupic.geospatial python error on Ubuntu 14

Hi! While doing the geospatial youtube tutorial I came across this error when executing

I think I have nupic porperly installed as I passed nupic test and could run onegym anomaly and prediction, sine-prediction and other examples.

Thanks in advance!

That example code has not been updated to use the latest version of NuPIC, which includes breaking changes described here. You can fix this by adjusting what version of NuPIC you have installed (see the thread).

Thanks again Matt! I’ll check it now

That being said, it would be nice if someone updated the example to work with the latest NuPIC. Perhaps once 1.0 is release I’ll try to update all the examples.

I could solve first issue thanks to this post changing
src/nupic/frameworks/opf/ -> src/nupic/frameworks/opf/

However when I try to run the simulated route I get this:

I got into and I think the error comes from here and when reading code I didn´t arrive to any conclusion…

I already tried git checkout and didn’t work.

Thanks in advance!

As noted in my 2nd PR in the breaking changes thread:

In any model params, change the model from CLA to HTMPrediction, like this:

  • ‘model’: ‘CLA’, ==> ‘model’: ‘HTMPrediction’,

Yep, totally forgot to search for that one! However I still get an error…

I tried to follow the trace and find what was wrong but didn´t arrive to anything

Thanks again!

That error would be the very first breaking change mentioned in the other thread:

Yep, already changed but still got more issues… I´ll be trying