Breaking change in 0.5.0: maxBoost vs boostStrength

I’ve seen this problem arise in several forms since we released NuPIC 0.5.0, so I wanted to put this out here to report (and collect additional) information about it.

We change the name of a Spatial Pooler parameter from maxBoost to boostStrength. This better reflects the true nature of the setting. It was causing confusion with people in the community (and ourselves). I’m happy we made this change, but it does mean you have to update your client code. We have updated all our examples, so referring to them should help.