Error running

I am running NuPIC in a Docker container on a MacBook. When I run the stock file, I get the following error before it is able to write the .csv:

Writing output to: hierarchy-demo-output.csv
Traceback (most recent call last):
  File "", line 368, in <module>
  File "", line 362, in runDemo
    runNetwork(network, numRecords, writer)
  File "", line 305, in runNetwork
  File "/usr/local/lib/python2.7/dist-packages/nupic-0.5.5.dev0-py2.7.egg/nupic/engine/", line 693, in run, n)
  File "/usr/local/lib/python2.7/dist-packages/nupic.bindings-0.4.5.dev0-py2.7-linux-x86_64.egg/nupic/bindings/", line 1147, in run
    return _engine_internal.Network_run(self, *args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/nupic.bindings-0.4.5.dev0-py2.7-linux-x86_64.egg/nupic/bindings/regions/", line 178, in guardedCompute
    return self.compute(inputs, DictReadOnlyWrapper(outputs))
  File "/usr/local/lib/python2.7/dist-packages/nupic-0.5.5.dev0-py2.7.egg/nupic/regions/", line 352, in compute
    categories = [category for category in inputs["categoryIn"]
KeyError: 'categoryIn'

I can run the other python files in the directory; I have run many times and it creates the 2000-line .csv file as expected.

Any clues from the error messages above? Thank you in advance. I have already pulled the latest NuPIC image and confirmed the same error.


I get the same error from a fresh installation on OS X.

@Containerhouse Can you create an issue about this and I’ll triage it?

Will do. Thanks for the quick reply, @rhyolight!

update: done/ issue created