How to Run HTM School Visualizations

visualization
tutorial

#42

:boom: I know the problem. You’re in Windows. :smiley:

Change the gifData folder to gifdata lower case d. That should fix it.

I’ll submit a fix today.


#43

I am using Ubuntu 16.04. And yes, actually I needed to change it to capital D! :smiley: Many thanks for your help. :slight_smile:

I killed the job and relaunched ‘npm start’. I see the image options now. The only little problem is that there are no thumbnails!


#44

I forget sometimes that OS X is not case-sensitive. There is probably a similar problem with gif file names. Look in your console for more errors


#45

Great help. I digged through and all fixed now!

For your ready future reference, following lines need replacement
In https://github.com/htm-community/htm-school-viz/blob/master/static/js/ep10/choose-gif.js (and also in master/index.js)

Line 4

var gifData = undefined;

to

var gifdata = undefined;

Or replace-all gifdata with gifData

… Ah wait, I notice that you have fixed everything already! Great! :slight_smile: :clap::clap:


#46

Hello. What a great tool, thanks!

The only thing I have problems with is gifs selection. Gifs show up for me, but when I click on them, I don’t get on http://localhost:8001/client/ep10/topology.html?load=<GIF-NAME>. I’ve inspected the element and they look like this:
image

I’ve tried replacing the link in <a> tag with a full one (starting with http://localhost:8001/client/ep10), but still, nothing happens when I click on it. And if I go to the page manually, everything looks fine there.


#47

I installed this on my ubuntu-machine and when calling webpack in $CELL_VIZ, there is no dyson.js created. It generates ‘dist/cell-viz-3d-1.4.9.bundle.js’ and I am not sure to where I need to link this.

But nevertheless I was able to run the server and start some simulations. But unfortunately when running the simulation “Many GCMs” from episode 14, the menu in the right upper edge of the screen does not appear so I can’t change the settings. Do you know why this could be the case? I would love to change the settings like you do in the video.

Thanks!


#48

I think this are old instructions. If it works, it is working. :stuck_out_tongue:

Uncomment this line:


#49

Thank you very much! This solved it.