HTM Engine Installation error


#1

Dear all,

I am trying to install the HTM Engine but I am not being able to do it. When I run “cd numenta-apps/htmengine python setup.py develop --user” I am encountering an error that I am sending in attachment.

Does anyone know how to solve this?

Thanks,
Best regards,
José Santos


#2


#3

First part of the log:


#4

I don’t think you have NuPIC installed properly. Please make sure you have it installed first and can run examples. See https://github.com/numenta/nupic/wiki/Installing-and-Building-NuPIC.

Also, pasting the actual log text is much better than images of the log text, because it is searchable. Better yet, paste your logs to pastebin or gist and link to them from here?


#5

I have no problems running nupic. I have tested some prediction and anomaly tests. But now I would like to install the HTM Engine so that I can run multiple tests at the same time.

My system is a Ubuntu 15.10 VM.

Link for the log: http://pastebin.com/KWzvWy5e


#6

It looks like the build is choking on Cap’n Proto installation, which should already be installed if NuPIC is installed. I hope maybe @Austin_Marshall or @vkruglikov can help.


#7

See https://github.com/numenta/numenta-apps/issues/75


#8

#9

This bug has been fixed in capnproto some time ago for capnproto >= 0.5.2:


#10

The bug has not been fixed in capnproto-c+±0.5.1.2.tar.gz which is pulled during the pycapnp install.

A quick fix would be to install capnproto manually before running the nupic install:

https://capnproto.org/install.html#installation-unix

or upgrade pycapnp to version 0.5.7 or greater (which will update bundled libcapnp to v0.5.2):

pip install pycapnp -U --user


#11

HTM engine requires nupic==0.3.4 which has pycapnp 0.5.5 as a requirement (see https://github.com/numenta/nupic/blob/0.3.4/external/common/requirements.txt)


#12

@jpedro Maybe you could try this workaround:

Edit the file numenta-apps/htmengine/requirements.txt; change the line nupic==0.3.4 to nupic==0.5.4. Then try the installation again (python setup.py develop --user).


#13

Thank you both for the help! I manually installed capnproto and I was able to solve the issue.

Currently, I am having trouble with the model_scheduler on supervisor. The other services work fine.

AllMessageQueues
params={“columns”: “name”})
File “/root/.local/lib/python2.7/site-packages/requests-2.0.1-py2.7.egg/requests/api.py”, line 55, in get
return request(‘get’, url, **kwargs)
File “/root/.local/lib/python2.7/site-packages/requests-2.0.1-py2.7.egg/requests/api.py”, line 44, in request
return session.request(method=method, url=url, **kwargs)
File “/root/.local/lib/python2.7/site-packages/requests-2.0.1-py2.7.egg/requests/sessions.py”, line 361, in request
resp = self.send(prep, **send_kwargs)
File “/root/.local/lib/python2.7/site-packages/requests-2.0.1-py2.7.egg/requests/sessions.py”, line 464, in send
r = adapter.send(request, **kwargs)
File “/root/.local/lib/python2.7/site-packages/requests-2.0.1-py2.7.egg/requests/adapters.py”, line 356, in send
raise ConnectionError(e)
ConnectionError: HTTPConnectionPool(host=‘localhost’, port=15672): Max retries exceeded with url: /api/queues/%2f?columns=name (Caused by <class ‘socket.error’>: [Errno 111] Connection refused)

I wasn’t able to use pastebin again, because I am a new user on the forum, sorry.


#14

Maybe this error occurs because you’re running the software as root. I’ve seen errors like this in the past when people used root instead of a regular user.

If you don’t have a serious reason to do so (and I’m sure you don’t), I would recommend to try the installation again with a regular user.


#15

I reinstalled nta_utils and htmengine as non root, but the same error occurs.

Here the complete log of the model_scheduler. I am running the htmengine-traffic-tutorial.

link: http://pastebin.com/DKjgbuEQ


#17

@jpedro Do you have the RabbitMQ management plugin enabled? You can check this by opening http://localhost:15672 in your browser. If you don’t get a login site, please enable the plugin by running this command:

sudo rabbitmq-plugins enable rabbitmq_management

Once you’ve done that, again open/reload http://localhost:15672 in your browser. You should now be able to login with username “guest” and password “guest”. If so, please try to run the model_scheduler on supervisor again.


#18

Thank you very much, that solved the problem. Now I am facing another issue, this time with npm start.

I have my webapi.py running but when I run “npm start” this happens:

Link: http://pastebin.com/YmEGuUZw


#19

No problem, small snippets are fine.


#20

You do have to install nodejs for npm to work.


#21

I reinstalled nodejs and it’s working now. My version was deprecated. Thank you both!