HTM Python Version Installation Problem


#1

Hi,guys.I need some help.When I was using Ubuntu14.04 to install nupic,there are some problems.I used pip install nupic for installation just as the readme.md told me,but the error message shows that a compiler with support for c++11 is required.But I already have gcc which the version is 5.4.1.According to the error message ,I can’t install pycapnp because of the compiler thing.Can you tell me how to solve the problem?


#2

We very recently updated NuPIC so you should be able to simply run pip install nupic from the command line to install on Ubuntu. Try uninstalling anything you already have by running pip uninstall nupic -y and pip uninstall nupic.bindings -y a few times, then try again with the simple pip install nupic command.


#3

That’s odd.I’ve tried the simple command pip install nupic. But it didn’t work. There were some problems installing the pycapnp module.That is the biggest problem.Now I turn my gcc version into 4.8.4. The Internet shows that this version can support c++11,but the error message still shows “a compiler with support for c++11 is required”. What else should I do before using the command pip install nupic? Thank you very much.


#4

Thanks for reporting. I can see that pycapnp might be a problem because it requires installation of the Capnproto C++ library.

You might have more than one gcc compiler installed, and the pycapnp build is picking up the wrong one. Try setting the following environment variables:

export CC=gcc
export CXX=g++

Also, confirm that gxx --version returns the version you expect.


#5

Yes,that’s what I need.Thanks a lot.


#6

We run nupic in ubuntu 14.04. You might find the build scripts at https://github.com/numenta/nupic/tree/master/ci/bamboo informative as they include ubuntu-specific instructions.