Install failed Ubuntu 15.10

Everything went great until the tests. I have tried and tried to get a clean install?
Followed video many times sill errors out on tests.

Inline console output moved to gist by @rhyolight


Tried a third time new VM
Still get same 18 failed test and errors

1 Like

Right away, this tells me that NuPIC is not installed correctly. Tests cannot even run in some cases, because the C++ code behind nupic.math is not being imported. This means that nupic.bindings is not installed properly.

Run this and tell me the outcome:

python -c 'import pkg_resources;n=pkg_resources.get_distribution("nupic");b=pkg_resources.get_distribution("nupic.bindings");print n.project_name, n.version;print b.project_name, b.version'

It should print out the installed versions of both nupic and nupic.bindings.

Here is output. I even started from another clean install and followed video exactly.
Thank you so much for your help,

fursty@ubuntu:~/nupic$ python -c 'import pkg_resources;n=pkg_resources.get_distribution(β€œnupic”);b=pkg_resources.get_distribution(β€œnupic.bindings”);print n.project_name, n.version;print b.project_name, b.version’
nupic 0.5.5
nupic.bindings 0.4.5

I assume you followed the video for binary installing, meaning you ran pip install to install it. It would be helpful to see the output of the pip command if you can provide it.

Thank you - I save snapshots along the way. So I reverted to the pip install and here is what I get

fursty@ubuntu:~$ pip freeze | grep nupic
fursty@ubuntu:~$ pip install nupic --user

Successfully built DBUtils python-dateutil asteval mock validictory coverage psutil prettytable ordereddict PyYAML pycapnp unittest2 pyproj
Installing collected packages: DBUtils, python-dateutil, asteval, mock, validictory, PyMySQL, coverage, psutil, prettytable, ordereddict, PyYAML, pycapnp, unittest2, pyproj, nupic
Found existing installation: coverage 4.2
Uninstalling coverage-4.2:
Successfully uninstalled coverage-4.2
Successfully installed DBUtils-1.1 PyMySQL-0.6.2 PyYAML-3.10 asteval-0.9.1 coverage-3.7.1 mock-1.0.1 nupic-0.5.5 ordereddict-1.1 prettytable-0.7.2 psutil-1.0.1 pycapnp-0.5.8 pyproj-1.9.3 python-dateutil-2.1 unittest2-0.5.1 validictory-0.9.1

Again Thank you - been trying for a week to get this up an running test successfully.

Here is the PIP

fursty@ubuntu:~$ curl | sudo python
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 1488k 100 1488k 0 0 2090k 0 --:–:-- --:–:-- --:–:-- 2091k
The directory β€˜/home/fursty/.cache/pip/http’ or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.
The directory β€˜/home/fursty/.cache/pip’ or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.
Collecting pip
Downloading pip-8.1.2-py2.py3-none-any.whl (1.2MB)
100% |β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ| 1.2MB 690kB/s
Collecting setuptools
Downloading setuptools-27.3.0-py2.py3-none-any.whl (467kB)
100% |β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ| 471kB 2.2MB/s
Collecting wheel
Downloading wheel-0.29.0-py2.py3-none-any.whl (66kB)
100% |β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ| 71kB 4.9MB/s
Installing collected packages: pip, setuptools, wheel
Successfully installed pip-8.1.2 setuptools-27.3.0 wheel-0.29.0

Did you run this as specified in the README?

pip install

This command installs the nupic.bindings python module, which maps python onto the C++ nupic.core code.

Yes I grabbed the syntax per the video that was on the readme


Let’s try running NuPIC. If you have it installed properly this should work.

If you haven’t got the source code locally, check it out or download it, then run this from the checkout directory:

> python examples/opf/clients/hotgym/simple/

It should print something like this:

INFO:__main__:After 100 records, 1-step altMAPE=23.183145
INFO:__main__:After 200 records, 1-step altMAPE=21.548877
INFO:__main__:After 300 records, 1-step altMAPE=21.227594
INFO:__main__:After 400 records, 1-step altMAPE=20.686270
INFO:__main__:After 500 records, 1-step altMAPE=20.417234
INFO:__main__:After 600 records, 1-step altMAPE=20.852339
INFO:__main__:After 700 records, 1-step altMAPE=20.907660
INFO:__main__:After 800 records, 1-step altMAPE=21.137106
INFO:__main__:After 900 records, 1-step altMAPE=20.875763
INFO:__main__:After 1000 records, 1-step altMAPE=20.789707

If you get an error or something different, please show me. Thanks!

So I redid this with a clean install again, based on the video. The tests -u failed again- same 18 errors.
I ran the hotgym script above and got the output you show.
So at this time, it may appear that nupic is installed correctly ? I will run further tests as well from the examples.
I greatly appreciate your help and timely responses. Thank you.

I would just like to add that I am having EXACTLY the same problem. In my case I have tried Ubuntu versions 15.10 as well as 16.04LTS, and these same versions on clean VirtualBox setups.

Notice though that I am too only using AMD64 CPU, in all these instances, which seems to be a common trait.

@gbytze @wunder007 Thanks for hanging in there. Glad you can run that script, because that at least proves that NuPIC is installed. I think the problem may be in the environment running tests, but it is hard for me to tell where. It could be that the python environment invoked when running py.test is different from that you run from the command line directly. I really don’t know, but the fact that the hotgym sample script works tells me that you should be in a good state. If anything abnormal happens while you are working, please let me know.

I am trying the Hot Gym Tutorial with the install on Ubuntu 15.10 and will see where it ends up.