Numpy version conflict error on OS X El Capitan

The following error might come up while running nupic tests after installation if you system numpy version is 1.8.

pkg_resources.VersionConflict: (numpy 1.8.0rc1 (/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python), Requirement.parse('numpy==1.9.2'))

The required numpy version for nupic is 1.9.2. To resolve this error, before installing numpy version 1.9.2, make sure that your $PYTHONPATH is set to /Users/<yourusername>/Library/Python/2.7/lib/python/site-packages.

export PYTHONPATH=${HOME}/local/lib/python2.7/sitepackages: /Users/<yourusername>/Library/Python/2.7/lib/python/site-packages:/usr/local/lib/python2.7/site-packages:${PYTHONPATH}

Thanks @zagha :smile:
Would you mind adding this it to the NuPIC setup FAQ?

1 Like

Just added it to Nupic setup FAQ :slight_smile: