Nupic Installation Error on Windows


#1

When I was trying to install nupic, I received following error message:

Could not find a version that satisfies the requirement nupic.bindings==1.0.6 (from nupic) (from versions: 528bb8eb85fc9b30b624545fb4187d3d9f38e65b, 0.4.2, 0.4.3, 0.4.4, 0.4.5, 0.4.6, 0.4.7, 0.4.8, 0.4.9, 0.4.10, 0.4.12, 0.4.13, 0.4.14, 0.4.15, 0.4.16, 0.5.0, 0.5.1, 0.5.3, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.7.0, 0.7.1, 0.7.2, 1.0.0, 1.0.1, 1.0.2, 1.0.3)
No matching distribution found for nupic.bindings==1.0.6 (from nupic)

I followed the installation instructions and my current environment is:

Win 10
Python 2.7.9
pip 10.0.1
setuptools 39.2.0
wheel 0.31.1
nupic.bindings==1.0.3

I was also attempted to upgrade nupic_bindings to 1.0.6 by using pip install nupic.bindings --upgrade but got the following error:

 Could not find a version that satisfies the requirement nubic_bindings (from versions: )
No matching distribution found for nubic_bindings

I finally tried pip install nupic.bindings==1.0.6 but received:

Could not find a version that satisfies the requirement nupic.bindings==1.0.6 (from versions: 528bb8eb85fc9b30b624545fb4187d3d9f38e65b, 0.4.2, 0.4.3, 0.4.4, 0.4.5, 0.4.6, 0.4.7, 0.4.8, 0.4.9, 0.4.10, 0.4.12, 0.4.13, 0.4.14, 0.4.15, 0.4.16, 0.5.0, 0.5.1, 0.5.3, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.7.0, 0.7.1, 0.7.2, 1.0.0, 1.0.1, 1.0.2, 1.0.3)
No matching distribution found for nupic.bindings==1.0.6

Any suggestions?


#2

I’m not sure what the problem is, nupic.bindings 1.0.6. is right here. You might try Uninstalling NuPIC and reinstalling from scratch.


#3

It looks like your python is 32-bit application. From the pip -v install nupic.bindings it looks like the last version, that supports 32-bit app is 1.0.3. You have to download 64-bit application. I.e. using this link: https://www.python.org/downloads/windows/
Please note, python.org provides 32-bit app as default.