Problem installing Nupic with pipenv

Hi guys,

I tried to install nupic with pipenv and encountered problems.
Much appreciated if someone has done it before could give me a hand.
I work on a win7 desktop and here’s how I ran it.

Create a venv with Python2, OK.

pipenv --two

Install numpy, OK.

pipenv install numpy

Install nupic

pipenv install nupic

Then it outputed something I don’t know what to do about

Installing nupic…
Adding nupic to Pipfile’s [packages]…
Installation Succeeded
Pipfile.lock (b0e3b2) out of date, updating to (57a39c)…
Locking [dev-packages] dependencies…
Locking [packages] dependencies…
Locking Failed!
Traceback (most recent call last):
File “E:/Python37/Lib/site-packages/pipenv/”, line 126, in
File “E:/Python37/Lib/site-packages/pipenv/”, line 119, in main
parsed.requirements_dir, parsed.packages)

I can install nupic without virtural environment setting, though.
Any idea? :upside_down_face:

Hi David,

Welcome to the forums!

Based on the file paths in the output, it looks like Python 3.7 is actually being used.

What is the output of:
pipenv --support

1 Like

I should add, you might want to look at htm.core instead of nupic, as Python 2 is not long for this world.

Big thanks @jimmyw, I’ll look at htm.core.
btw, pipenv --support gave me Python3.7’s location. Looks like I did it in the wrong way.

1 Like