Running NuPIC on Raspberry Pi...having problems

question
nupic

#21

Nope, I’ve tried several things, but I keep getting that same error.

Can you tell me how I can replace the maxBoost parameter in the python code I am using, to do what the new parameter (boostFactor) does? Unfortunately just renaming it or getting rid of it doesn’t work.:head_bandage:


#22

You mean after changing maxBoost ==> boostFactor you are still getting this?

RuntimeError: Unknown parameter 'maxBoost' for region 'SP' of type 'py.SPRegion'

That is strange :thinking:


#23

Actually, when I change it to “boostFactor” then it gives me an error saying:
RuntimeError: Unknown parameter 'boostFactor' for region 'SP' of type 'py.SPRegion'


#24

I’m sorry, it was boostStrength not boostFactor.


#25

Oh, well I don’t have that error anymore. I’ve got a new error though:
RuntimeError: Unknown parameter 'clVerbosity' for region 'Classifier' of type 'py.CLAClassifierRegion
but I fixed it by changing 'clVerbosity' to 'verbosity'
so now everything works. :smile:


#26

The verdict is that the Raspberry Pi 3 can perfectly run NuPIC if installed correctly.


#27


#28

good meming :laughing:


#29

Reassuring! Step 1: Did you install under Raspbian or Ubuntu?
I’ve been trying on/off for weeks to install on a Raspberry Pi 3 under Raspbian Jesse. I have a 36 pp log of failed steps. Successfully installed ROS under Ubuntu Mate on same machine and willing to switch if necessary. It would be SO NICE for us floundering newbies for someone at Numenta to maintain a current, tested & verified install script for NuPIC on the common platforms to include, please, the Raspberry Pi. Short of that, a step-by-step installation guide from someone who’s successfully climbed the mountain? Many thanks in advance!


#30

It will be up to the community to provide this. Many have forged this path ahead of you and left hints in other forum posts. We at Numenta are focusing all our efforts on continuing HTM research, so we can’t put engineering time into a platform unless we plan on testing or experimenting with them, and Raspberry Pi is not a target for us. :frowning:


#31

I’ll put together something more comprehensive (if someone else doesn’t get to it first). My spare Pi is currently tied up running a Christmas light show, so I’ll have to use QEMU to start documenting the process, and I’ll post my results from that. I’ll just won’t be able to verify on actual hardware until after the holidays.


#32

Quick update on my own progress. I’ve gotten through installation of most of the dependencies (thinking I’m probably still missing some). I haven’t successfully built NuPIC core on Raspbian yet, but it is getting much further along now.

I’ll keep at it until I get it, and might post some questions if I get stumped on something that others might have solved. I am compiling comprehensive instructions as I go, and I’ll run through it all from the beginning a few more times to verify and optimize if necessary once I am successful.


#33

I’ve gotten NuPIC Core built, and all tests pass.

I installed the nupic.bindings Python library and ran the tests. Got some errors, and thought I would see if anyone has seen these before: https://gist.github.com/paulscode/0a97f5854a28667de080ec13cada670d

Seems to be a problem with capnp:

bindings/py/src/nupic/proto/RandomProto.capnp:0: failed: Duplicate ID @0x88eaee6db8e1f67c

I ran the capnp “make check”, and all tests show as passed. Also verified the correct version is installed. I’ll check if pycapnp has its own tests.


#34

Found this issue on GitHub… rather old, but it is still in Open status and the “Duplicate ID” message is a commonality. Scott mentioned doing the “editable”/“develop” installations, so I’ll give that a shot when I get home from work this evening, and see if that solves it.


#35

Looking much better after that change. Still one failed test for nupic.bindings Python library. I’ll investigate that one.

Here are the current test results, for reference: https://gist.github.com/paulscode/4dfb749caa8e04bac5d91b255ce7d1e3


#36

I’m not at all familiar with Python C++ binding, so sorry if this is a dumb question, but it seems to me that the error message about “wrong number or type of arguments” is incorrect. Shouldn’t the three lines I have highlighted match?

image

Has anyone encountered this particular error before?

–EDIT–
Found this on Stack Overflow. Possibly related since the setDimensions function call is passing a temporary. Will check on this.

I’m wondering if the version of C++ on latest Raspbian is enforcing best practices a little more aggressively than the versions NuPIC core 1.0.0 was originally tested with. I ran into another issue earlier where some code in NuPIC core was trying to throw an exception within a destructor (bad practice) and the compiler was failing out (I had to modify the code to get past that one).


#37

I have gotten NuPIC to install, and it passes 692 of the unit tests. Still have the failed test case I mentioned above for the nupic.bindings Python library, plus 17 failed test cases for NuPIC itself.

Rather than keep flooding this thread as I work through the issues, I think it might make better sense to start a wiki and improve on it over time. To that end, I have posted the instructions I’ve compiled thus far. @rhyolight do you mind turning that into a wiki?