Unsupported Model type

Hi everyone !
I’m about to run HTM for the first time. I’m following the instructions given in:

but I get an error related to the model_params.
The error is as follows:

Traceback (most recent call last):
File “<pyshell#85>”, line 1, in
model = ModelFactory.create(MODEL_PARAMS)
File “C:\Python27\lib\site-packages\nupic\frameworks\opf\modelfactory.py”, line 78, in create
Exception: ModelFactory received unsupported Model type: HTMPrediction

Do you have an idea about that ?
Thanks in advance.

1 Like

I do have an idea. This was a recently introduced breaking change. I have a post on that thread with instructions on how to sync your local code checkout with your NuPIC installation. Let me know if you need further help.

1 Like

me too have the error ( execption: modelFactory received unsupported model type: CLA ) , and i fixed the name of moduls
modelfactory ==> model_factory
predictionmetricsmanager ==> prediction_metrics_manager
but this is the error

In your model params, change

"model": "CLA"


"model": "HTMPrediction"

sorry but the same Error

What file in your program did you change? There is a misconfiguration somewhere if you think you’ve changed the config and it hasn’t actually changed. You need to find the place in your code where you read in the config and make sure that file is the one you are editing.


In fact, I’ve wanted to test this example of github

and I motifier this file : C:\Users\dell\Desktop\les algorithmes\nupic.subutai-master\ensembles\model_params.py
I change “model”: “CLA” to “model”: “HTMPrediction”

@way-sal What version of NuPIC do you have installed?


the last version nupic


Here’s some things to try to be able to troubleshoot your setup;

  1. Got to that directory where model_params.py is located. And issue the following command, make sure you are using the right python interpreter.

python -c "import model_params; print(model_params.MODEL_PARAMS.get('model'))"

If you have updated the model to "HTMPrediction" properly then it should print "HTMPrediction". If it still prints "CLA" then there is something wrong with your setup.

  1. If it printed "HTMPrediction" then make sure you are running the source code in the same directory where the model_params is located (recommended), otherwise you have to set PYTHONPATH environment variable.

If it printed "HTMPrediction" and you ran the source in the same directory as model_params.py is located, and still you get the same error, then there must be some incompatibility with that code you are trying with your latest nupic version, this is probably what @rhyolight is getting at.


hi @rhyolight,
after changing some names of modules, I have this problem of datasethelpers do you know the updates in the new version

See this commit for breaking changes and examples of how to fix the breaks: