Failed unit tests on Windows and Ubuntu

I am trying to install NuPIC and run the unit tests. I have tried to install from pip as well as build from source for the following systems: Windows 10, Debian 8, Ubuntu 16.04 and Ubuntu 14.04. I get the same result on all of them and the unit tests run with errors. I’m not sure what I am doing wrong as I have followed the directions on the NuPIC repo

I’m not sure what other information to post that would be helpful to diagnose the problem. I see that the project builds on Travis CI yet I am unable to replicate the install.

1 Like

When I tried the tests/unit folder, I found lots of import error. Many modules’ name have changed during nupic ungrades, but the test code there didn’t update accordingly. Are you having the same problem?

This should help with breaking changes:

If that does not help, I will need to see the console output from the nupic installation to help diagnose installation problems.

Here is the gist to the nupic-bindings-check after installation.

And here is the gist for the py.test output.

I also made sure both nupic.core and nupic were at tip of master when installing from source.

Looks like most of the errors come from Cap’n Proto having a duplicate ID.

Are you sure there were no errors when you compiled nupic.core?

The output to std error was several hundred lines long. Here is the gist for the std error.

What C++ compiler are you using? It must be C++11 compatible.

$ g++ --version
g++ (Debian 4.9.2-10) 4.9.2
Copyright (C) 2014 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
$ echo -e "#include <iostream>\nint main(){std::cout<<\"Hello C++11\"<<std::endl;return 0;}" > input.cpp && g++ -std=c++11 input.cpp && ./a.out
Hello C++11

Great, but I’m not sure what to make of your error output. The test errors point to Capn Proto problems. You could try to install capnp manually. That has helped me in the past.