MNIST error


#1

Hi, I tried to run the mnist test file htmresearch/projects/image_test/run_mnist_experiment.py and I got the following error RuntimeError: Matching Python module for ImageSensor not found.. I tried to google it and found these two topics:


I followed the instructions and tried to install nupic.vision (I am now able to import nupic.vision even from nupic.vision.regions.ImageSensor import ImageSensor works), but after running the mnist experiment again I get the same error. Could someone please give a step by step manual how could I get the experiment running from scratch? It looks like a cool project and it is really frustrating that it doesn’t work right out of the box.


#2

I see on that same thread, at the tail-end of it, this hint was given.

Try that. :slight_smile:


#3

Thanks for the reply. I read that hint, the problem is that it is quite old and in the latest version of the file there is no parameter maxBoost and the line 166 looks different. I tried to search for the line and found two lines that probably do the same, I removed them but it did not help.


#4

The tip version of nupic.vision already incorporates all the needed changes and should run with no changes. I just tried it.
Perhaps your Python path does not include nupic.vision/src.


#5

Can I ask what is the exact configuration you are running the experiment in? I have nupic.vision/src in my python path and I am still getting the same error.


#6

I am running Anaconda Python 2.7 on Mojave on a Mac.

This is my command line:
~/Development/nupic.vision/src#python nupic/vision/mnist/run_mnist_experiment.py --data-dir ./nupic/vision/mnist/data

Note that I am running this from the nupic.vision/src folder. Hence I even do not have to set the python path to here for this to work.


#7

Thank you! I finally got it working. The problem was that I tried to run the experiment in htmresearch repository and not the one in nupic.vision.