Test nupic with py.test


#1

Hi, All,

I just installed nupic following the instruction on github, and I tried to run the suggested test

From the root of the repo:

py.test tests/unit

However, the directory was not found.

I found the directory here,

I ran $ py.test unit, and I got the following response

============== test session starts================================
platform darwin – Python 2.7.12 – pytest-2.5.1
plugins: cov, xdist
collecting 6 itemsAbort trap: 6

Can anyone tell me where I did wrong ?

Thanks !

Po-Hsuan


#2

Run tests like this from the nupic repo:

> cd scripts
> python run_nupic_tests.py -u
================================================= test session starts ==================================================
platform darwin -- Python 2.7.10 -- pytest-2.5.1 -- /usr/bin/python
plugins: cov, xdist
collected 887 items / 5 skipped

#3

Hi,when i run this command,i got 25 failed.Most of them are about spartialPoolerTest,and “tests/unit/nupic/research/temporal_memory_test.py:1027: AssertionError” as well. I follow all the steps on the github and there is no error message while installing it.Any advice?Thanks!


#4

Can you capture the entire console output of the test command and paste in pastebin.com or gist.github.com please?