Test_db failure on Ubuntu


@rhyolight thanks for your suggestions. Since I had some other problems in MacOSI installed it from source on Ubuntu running on a VM. I followed the instructions in https://github.com/numenta/nupic/wiki/Compiling-NuPIC-on-Ubuntu-14 and everything worked just fine except the test of the DB. After installing MySQL, when I run: python $NUPIC/examples/swarm/test_db.py y get the following error:

ImportError: No module named support.configuration

Any ideas?

Install on Mac OS failed unit tests

If you got an error like this:

> python test_db.py
Traceback (most recent call last):
  File "test_db.py", line 29, in <module>
    from nupic.support.configuration import Configuration
ImportError: No module named nupic.support.configuration

That means NuPIC is not properly installed. Can you get to the console output of the installation commands? If you can, look through them for any errors. If not, you should re-run the installation after running:

pip uninstall nupic -y; pip uninstall nupic.bindings-y

Be sure to watch for any errors on each step of the installation.

Also, what version are you installing? What is the commit SHA at the source you’re using?


The installation of Nupic Core does not show any errors. There are a few errors on the logs of the cpp_region_test but at the end it says ALL TESTS PASSED

Similar with unit tests, there are some errors and at the end it says
304 Tests from 42 test cases ran
PASSED 304 Tests

I am installing the latest version. The commit SHA is d4662ba3d0a9c4ed2ff92078484be9a989cb6419


Please paste the exact console output you are getting when you run test_db.py. Mine looks a little different than the error you posted.


@rhyolight I tried installing it all over again on a new VM with Ubuntu 16.10 but this time go errors when running make j3 (last time , with the old VM did not have any problems during installation).

Again I followed the instructions in https://github.com/numenta/nupic/wiki/Compiling-NuPIC-on-Ubuntu-14.

Attached please find the errors. Any ideas?

Thanks for all your support!


Sorry, but the last Ubuntu I tried (and failed) was Ubuntu 15. I don’t have an installation guide fro anything above Ubuntu 14 yet, so if you figure anything out, please share with us.


I did an install on Mint 18 sort of recently (November/December 2016). I followed the same instructions and hit two issues - I don’t know if it will help but here is what I saw.

I was building everything from source, and I had some compile issues related to not building from the correct tags on the the two repositories. I had to go back and make sure that I was at the right tag, and rebuild everything.

The second issue was that it looks like an empty password works with sql-server 5.7. I had to dig around forums for a while to figure out how to really have an empty password in order to connect to the root account.

I was able to get it working though. I’m currently able to use NUPIC with the db for swarming on Mint 18. So I think it should be possible to do it on a more recent build of Ubuntu as well.

Good Luck!


@mgstrein @rhyolight thanks for your comments!

I finally went back to Ubuntu 14 , follow the instructions on got it to work fine.

On Ubuntu 15, the installation and tests went fine, the problem occurred after I installed and tested de database, maybe it had to do with using an empty password just like @mgstrein said.


If I recall correctly, MySQL on Ubuntu 15 didn’t allow creation of the root user with an empty password. Nupic has a config file that has user and password settings for MySQL that default to user=root and password="". You can change those config items to make it work with a non-empty root password. Also see this issue that describes a workaround: “ERROR running swarming tests using mysql user override without setting environment variable NTA_CONF_PATH” https://github.com/numenta/nupic/issues/3189